[CS-FSLUG] Virtual machines

Vincent Danen vdanen at linsec.ca
Fri Dec 1 11:13:09 CST 2006

* Frank Bax <fbax at sympatico.ca> [2006-12-01 11:47:54 -0500]:

> >VMWare works only on x86 architecture. Now that OSX runs on x86, I might 
> >expect them to port it, but that hasn't happened yet.
> Thanks, it doesn't work on OpenBSD either - so we'll drop that idea.  When 
> I first tried VMWare on WinXP, I hadn't yet had X running on OpenBSD.  It's 
> running now with Firefox and OOo, but not VMWare.

My understanding is that you can run vmware on FreeBSD using it's linux
emulator.  I don't know if OpenBSD has a similar emulator or not
(somehow I'm suspecting not), so you probably won't ever get OpenBSD to
run vmware for you.

> I just tried QEMU on OpenBSD with a copy of Win98SE virtual disk from 
> VMware and it "just works"!!  Win98 is complaining about some new devices, 
> but seems to be working; no network access yet though.  I'll probably 
> reinstall Win98 to new virtual disk.  I see QEMU has downloads for OSX, so 
> perhaps that's the way to go...

There's also a GUI frontend to qemu (IIRC)... I tried it some time ago
and it had passable performance on my dual 1.8GHz G5... on a more modern
machine the performance might be better.  The nice thing about qemu is
that it can emulate just about anything... =)

{FEE30AD4 : 7F6C A60C 06C2 4811 FA1C  A2BC 2EBC 5E32 FEE3 0AD4}
mysql> SELECT * FROM users WHERE clue > 0;
Empty set (0.00sec)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 186 bytes
Desc: not available
URL: <http://ofb.biz/pipermail/christiansource_ofb.biz/attachments/20061201/d46d2a7b/attachment.sig>

More information about the Christiansource mailing list