[CS-FSLUG] Linux used to handle floppies really well.

davidm at hisfeet.net davidm at hisfeet.net
Sun Jul 31 08:30:13 CDT 2011

I had already tried mtools, and couldn't get it to work. After your notet,
I went back and studied the situation a little further. /etc/mtools.conf
mentions two files: fdimage and hdimage.first  Those two files don't exist
on my computer.

Also mtools appears to depend upon dosemu. I use dosemu every day, but the
directory /var/lib/dosemu/ also didn't exist on my computer. I made a
empty directory there, and put an image file there of a freedos floppy
(just as I downloaded it from the internet. I renamed it fdimage, and
tried again with some mtools commands. So far They work. They absolutely
will not cooperate with the udisks utilities, though. Any attempt to mix
the two results in a floppy freeze until a reboot:().

I'm still interested in expanding the utility of this desktop under linux
to use dos. mtools (far as I can see so far) is limited to the commands
that are part of the command interpreter. dosemu has much wider usage with
various programs, but so far I haven't been able to access the floppy
drive with it. But to tell the truth - I have plenty to do without
spending a lot of time on this, and I'm sure you do to.

My interest in getting back to dos right now has to do with the fact that
I was/am trying to revive some older computers, and trying to install some
variety of linux on them. Was inhibited somewhat by the fact that they
won't boot from the CD. One can download bootable dos images from the
internet. There are a lot of them available, but getting them from my
dos-inhibited desktop (or laptop) to a floppy drive for use in the older
machine has been a problem.  Maybe I can do that now.  Thanks.

> In the centos world, there is the mtools package.  Is that what you
> are looking for?
>      - Tim

More information about the Christiansource mailing list