[CS-FSLUG] udev and SATA DVDRs

Ed Hurst ehurst at soulkiln.org
Tue Jan 19 05:22:27 CST 2010

Marco Tedaldi wrote:

> And since all actual Linux distros mount the devices by uuid instead of
> devicename, there should be no problem if devicenames change (they
> should not change anyway).

It rebooted fine, but I still get error messages and the resulting CD is
not quite functional:

[  362.094030] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK
[  362.094038] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
[  362.094046] Info fld=0x0
[  362.094048] sr 1:0:0:0: [sr0] Add. Sense: Logical block address out
of range
[  362.094055] end_request: I/O error, dev sr0, sector 0
[  362.094062] Buffer I/O error on device sr0, logical block 0

This is the same thing seen in the various bug reports.

I noted in rereading the bug reports it seems the same error and
symptoms were used in a half-dozen bug reports, and the guesses were
different in each as to what the cause is. Lots of diagnostics, lots of
confirmations and reproducing the same errors and results, but then the
thread dies with no fix proposed. This goes all the way back to over a
year ago, and in different distros.

Ed Hurst
Associate Editor, Open for Business: http://ofb.biz/
Applied Bible - http://soulkiln.org/
Kiln of the Soul - http://soulkiln.blogspot.com/

More information about the Christiansource mailing list