[CS-FSLUG] Local Subversion Access Issue (Solved)

Vincent Danen vdanen at linsec.ca
Tue Aug 26 20:27:04 CDT 2008

* [2008-08-26 14:43:34 -0400] Don Parris wrote:

>> >> I created a repo in ~/dev/repos/pyplay, and use ~/bin/pyplay for my
>> working
>> >> copy.  I have edited the svnserve.conf in the /conf directory, and am
>> just
>> >> using the sample passwd file with my userid/password.
>> Using file:/// does not involve svnserve at all.  That's local file
>> access.
>> If this is a simple one-person repository, chown -R it, like Lincoln
>> said.  I'll bet you used root to create the repository to begin with
>> (don't do that).
>Thanks Linc & Vincent!  The chown -R trick was just what I needed.  In my
>case, I simply changed it to my normal user, since that's how I access the
>repository (it is in my home directory).  And I can check a file in directly
>from emacs - took me a second to figure out what to do, but only because I
>missed the initial message telling me how to enter my commit message.

Glad you got it working!  =)

>I have to confess, I think it's pretty cool to be able to edit the file and
>commit it right from within the text editor.  Yeah, I know.  I am s-u-c-h a

Yeah, but such is the pleasure of subversion.  Honestly, I'd be lost
without it.  So much better than cvs.

>Vincent, you are correct - I am using file:///, as opposed to svn:///, but
>was under the impression, based on the book, that you have to use the
>file:/// format when using svnserve.  Perhaps I misread or otherwise missed
>the boat on that point.  I also am not certain as to how *Ubuntu distros
>install SVN by default.  I saw no documentation to say what the default
>installation entails.

I don't think it varies by distribution.  Sure, some little things may
vary, but not how you manage repos.  The install really only entails the
placement of libraries and binaries.  Unless Ubuntu does something
really braindead like pre-create repos for you, but I can't imagine it

>You are also correct that I created the repo as root.  I had problems
>running svnadmin as my regular user - not sure why.  I seem to have the
>ability to do so now.  The only thing I can think of is that I may have
>accidentally created the /repos directory while I was sudo'ed as root - then
>tried to run svnadmin as a regular user to create the actual repository.  I
>can't swear to that, but if so, I probably ran svnadmin as root and
>discovered it worked - kind of.  :-)

I suspect you probably created the top-level directory as root, and as
such only root had write permissions to it.  Simple enough mistake.  =)

>Anyway, thanks for the help!

You're welcome.  =)

Vincent Danen @ http://linsec.ca/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
URL: <http://ofb.biz/pipermail/christiansource_ofb.biz/attachments/20080826/c1c60eab/attachment.sig>

More information about the Christiansource mailing list