[CS-FSLUG] Local Subversion Access Issue (Solved)

Don Parris parrisdc at gmail.com
Tue Aug 26 13:43:34 CDT 2008

On Tue, Aug 26, 2008 at 11:55 AM, Vincent Danen <vdanen at linsec.ca> wrote:

> * [2008-08-26 07:32:42 -0400] l4c at thelinuxlink.net wrote:
> >> I recently installed Subversion on a laptop running Kubuntu 8.04.  I am
> just
> >> playing with this, and using my python adventure to help me get used to
> it.
> >> I used Adept to install and, while I can pretty much do what I need to
> do, I
> >> seem to have problems committing files once I've checked them out.  I'm
> >> guessing that my regular user has only read access to the repository.  I
> can
> >> check out the repo, but cannot commit without doing:
> >>
> >> sudo svn commit file:///...
> >>
> >> Trying this fails.  It also affects my efforts to update from within
> emacs.
> >> svn commit file:///...
> >>
> >> I created a repo in ~/dev/repos/pyplay, and use ~/bin/pyplay for my
> working
> >> copy.  I have edited the svnserve.conf in the /conf directory, and am
> just
> >> using the sample passwd file with my userid/password.
> Using file:/// does not involve svnserve at all.  That's local file
> access.
> If this is a simple one-person repository, chown -R it, like Lincoln
> said.  I'll bet you used root to create the repository to begin with
> (don't do that).
Thanks Linc & Vincent!  The chown -R trick was just what I needed.  In my
case, I simply changed it to my normal user, since that's how I access the
repository (it is in my home directory).  And I can check a file in directly
from emacs - took me a second to figure out what to do, but only because I
missed the initial message telling me how to enter my commit message.

I have to confess, I think it's pretty cool to be able to edit the file and
commit it right from within the text editor.  Yeah, I know.  I am s-u-c-h a

Vincent, you are correct - I am using file:///, as opposed to svn:///, but
was under the impression, based on the book, that you have to use the
file:/// format when using svnserve.  Perhaps I misread or otherwise missed
the boat on that point.  I also am not certain as to how *Ubuntu distros
install SVN by default.  I saw no documentation to say what the default
installation entails.

You are also correct that I created the repo as root.  I had problems
running svnadmin as my regular user - not sure why.  I seem to have the
ability to do so now.  The only thing I can think of is that I may have
accidentally created the /repos directory while I was sudo'ed as root - then
tried to run svnadmin as a regular user to create the actual repository.  I
can't swear to that, but if so, I probably ran svnadmin as root and
discovered it worked - kind of.  :-)

Anyway, thanks for the help!

D.C. Parris
Minister, Journalist, Free Software Advocate
sip:dcparris at ekiga.net <sip%3Adcparris at ekiga.net>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ofb.biz/pipermail/christiansource_ofb.biz/attachments/20080826/6322f480/attachment.htm>

More information about the Christiansource mailing list