[CS-FSLUG] Strange boot problem

Tim Young Tim.Young at LightSys.org
Mon Nov 17 10:59:20 CST 2014

Ooohh Ahhh...  Exciting.  Boot problems are always a bit of a mess.

Briefly, there are two different partitioning schemes these days. 
Because you mentioned you have a "boot drive", I will assume you are 
using the "DOS partitioning."
The other partitioning scheme is the gpt partitioning system, which 
was created to allow large hard drives.  If you are using gpt, then 
life is a lot more exciting (and I have less experience with it.)

If you are using a "boot drive" (most likely a "boot partition") you 
actually need to put grub on /dev/sda1 (or whatever partition is 
labled with the boot flag).  In fdisk, I believe, the boot partition 
has a * next to it.  It is usually the partition that holds your 
/boot filesystem.

If you take the boot flag off the drive, it usually uses the grub 
info from the actual drive you are booting from (/dev/sda), but when 
you have the boot flag turned on, it uses the boot information from 
that particular partition (/dev/sda1)

Does that make sense?

     - Tim Young

On 11/17/2014 10:09 AM, davidm at hisfeet.net wrote:
> I'm having a strange problem with boot-up. I have three hard disks on the
> system, and have been able to boot from any one of the three in time past.
> It's a 64  bit system, but I have not used 64bit OSs on it before. Then I
> recently installed mint17 64bit. it installed properly, and worked just
> fine.  But I had several older OSs installed, and decided to eliminate
> them by reformatting the partitions where they resided.  Then I went back
> to Linux 17 64bit, and ran grub-install /dev/sdb (because that is the
> drive where said OS resides), and also grub-install /dev/sda, since that
> is the drive I normally boot from, and it is the drive marked as the
> 'boot' drive.
> I had eliminated all but two of my OSs: mint13 32bit, and mint 17 64.bit.
> Then went for a reboot, and got an error (apparently from Bios) that
> indicated a boot error, and ask me to insert a boot disk and reboot. I
> tried several things.  It would boot from a live cd, or DVD, and I know it
> is possible to "chroot" into the OS in any particular partition, but that
> is unhandy as a regular practice.
> I discovered that PlopLinux allows me to "boot from hard drive", and that
> choice takes me to the grub menu on whichever drive I have set in Bios to
> boot from.
> among the remedies I have tried without success: running grub-install from
> each of the installed OSs; using gparted to rewrite the boot sector; and
> installing a third OS (RoboLinux 64bit)
> I understand that the boot sector is ordinarily copied to varios parts of
> the hard drive, but have not been able to discover where. Is it possible
> to copy them from those locations to the boot sector? and if so: first,
> how do I find them, and second how do I copy them precisely to the boot
> sector?  Or is there a better method?
> So that's how I'm booting. Obviously the partition table is intact.
> gparted shos no errors.
> _______________________________________________
> ChristianSource FSLUG mailing list
> Christiansource at ofb.biz
> http://cs.uninetsolutions.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ofb.biz/pipermail/christiansource_ofb.biz/attachments/20141117/18bd89bc/attachment.htm>

More information about the Christiansource mailing list