[CS-FSLUG] I installed a DVD/CD burner, but...

davidm at hisfeet.net davidm at hisfeet.net
Mon Jan 20 17:53:40 CST 2014

Well actualy I had one installed, and then installed another so as to have
two. All the programs seemingly could find them both, and when I inserted
a disk in either one, it would appear on the desktop.
 Then I removed the first one that I had. The newer one works fine with
all the programs, and with LinuxMint13 Maya Mate 32bit (at least in GUI

Then I tried to set up a short script to eject with the Command "eject -T"
It doesn't work. I installed hwinfo and ran it, and got the following:

mint13- at mint13 ~ $ hwinfo --cdrom
25: SCSI 500.0: 10602 CD-ROM (DVD)
  [Created at block.247]
  Unique ID: KD9E.GKm1D8ZgMF5
  Parent ID: JZZT.AIVsB38mcOB
  SysFS ID: /class/block/sr0
  SysFS BusID: 5:0:0:0
  SysFS Device Link:
  Hardware Class: cdrom
  Model: "HL-DT-ST DVDRAM GH24NS95"
  Vendor: "HL-DT-ST"
  Device: "DVDRAM GH24NS95"
  Revision: "RN01"
  Driver: "sata_nv", "sr"
  Driver Modules: "sata_nv"
  Device File: /dev/sr0 (/dev/sg3)
  Device Files: /dev/sr0, /dev/cdrom, /dev/cdrw,
/dev/disk/by-path/pci-0000:00:08.1-scsi-0:0:0:0, /dev/dvd, /dev/dvdrw
  Device Number: block 11:0 (char 21:3)
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #12 (IDE interface)
  Drive Speed: 40
mint13- at mint13 ~ $ ^C

from terminal, this worked ONCE,
eject -T /dev/disk/by-path/pci-0000:00:08.1-scsi-0:0:0:0
 AS DID THE SIMPLE WORD "eject".  But then neither would work again.  I
can't see that it is listed in/dev  and I tried entering it in fstab
(with a folder at /mnt/cdrom), but all that did was cause it to hang on
boot with an error message until I press "s" to "skip" it.  In fact it
seems inaccessible to Linux at the terminal level.

k3b finds it.  Banshee,VLC, MoviePlayer, Audacity, etc. all seem to find
it without a problem. Why can't CLI find it? And what can I do about it?

More information about the Christiansource mailing list