[CS-FSLUG] Hard drive won't format - or maybe stay formatted.

davidm at hisfeet.net davidm at hisfeet.net
Wed Aug 4 20:51:05 CDT 2010

Trying to install linux on a vista machine that was not bootable when it
came to me. I tried to rescue windows, but after talking to the owner
decided she would be happier and better served with a good Linux install.

So a formatted the 250 GB drive to several partitions of ext3 and a swap
file (some of those partitions in a extended partition).  before I did, I
noticed that the ntfs partition that was there was preceded by an
unformatted area of perhaps 18GB. But I formated the whole drive with

When I got done I told Gparted to write the partition table. When I did
that the carefully laid out partitions disappeared from Gparteds screen. I
tried several times.  In between checked the disk And supposedly corrected
it with testdisk. Eventually I got the result that gparted began to look
only at the 232GB that was occupied by the original ntfs file.

At that point I went to studying if there was another approach, and cfdisk
was suggested. So I gave it a spin.  It found three poorly defined
partitions on the disk, and I deleted them all and made the whole disk one
partiton. But again when it wrote the partition table the partition

So I tried doing the partitioning within the install of linux
(Mint9-Isadora), but when it got to the end of the installation and wrote
Grub to the MBR, again the whole setup disapeared.

I thought about not letting it write the partition table to sda, but
rather to sda1, but Mint doesn't seem to have a way to do that unless I'm
missing something. And besides that would bring on a hassle when booting.

Is this drive just trash, or is there a way to get it right?

More information about the Christiansource mailing list