[CS-FSLUG] mini-ITX boot problem -- /dev names

Jonathan E. Brickman jeb at joshuacorps.org
Thu Apr 2 22:28:57 CDT 2009

On Thursday 02 April 2009 12:26:53 Stephen J. McCracken wrote:
> Marco Tedaldi wrote:
> > Ron Thompson schrieb:
> >> I spoke too soon.  It doesn't boot properly after swapping the
> >> cards, it gets started and them comes back with Checking root file
> >> system fsck.ext3: No such file or directory while trying to open
> >> /dev/hdb2 FAILED

I just read the whole thread again, and realized some significant import 
of the last line above.

Some distros, like RedHat, are still using /dev/hda, /dev/hdb, etcetera. 
This approach is causing the problems, for the reasons discussed. 
Distros using more recent IDE/EIDE/SATA setup (available via the same 
kernels which RedHat uses), are using /dev/sda, /dev/sdb, /dev/sdc, et 
cetera, for IDE, EIDE, SATA, and SCSI hard drives.

This accounts for why (a) two years ago, when I tried to install Puppy 
Linux on a few machines, I ran into /dev/hdxyz problems just as being 
discussed now, and (b) in the last week and a half I have installed the 
current Puppy (using the newer IDE/EIDE/SATA driver sets) on upwards of 
twenty different PCs, some SATA, some IDE, without a single hard drive or 
CD-ROM unfound, some with two CD-ROMs, some with four partitions on a 
secondary master hard drive, et cetera.  No matter what the 
master/slave/primary/secondary situation, they were all found, easily 
and straightforwardly.

I don't have a list of distros which are using the better IDE/EIDE/SATA 
driver set; I am very distressed to hear that RedHat is still using the 
one causing these problems.  I do know that Sabayon and Puppy use the 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ofb.biz/pipermail/christiansource_ofb.biz/attachments/20090402/eb58aadc/attachment.htm>

More information about the Christiansource mailing list